Table of Contents

HSRP Hot Standby Router Protocol

(Cisco) RFC2281

HSRP volba "active" routeru

Switch(config-if)# standby group(1-255 / 1-16) priority priority(0-255, def.100)

Po zapnutí HSRP musí zařízení projít následujícími stavy:

  1. Disabled
  2. Init
  3. Listen - ostatní routery
  4. Speak
  5. Standby - router s druhou nejvyšší prioritou
  6. Active - router s nejvyšší prioritou
Switch(config-if)# standby group timers [msec] hello [msec] holdtime
Switch(config-if)# standby group preempt [delay [minimum seconds] [reload seconds]]

HSRP Authentikace

Plain-Text Authentikace

Switch(config-if)# standby group authentication string

MD5 Authentikace

String:

Switch(config-if)# standby group authentication md5 key-string [0 | 7] string

Key-chain:

Switch(config)# key chain chain-name
Switch(config-keychain)# key key-number
Switch(config-keychain-key)# key-string [0 | 7] string
Switch(config)# interface type mod/num
Switch(config-if)# standby group authentication md5 key-chain chain-name

Track interface

Switch(config-if)# standby group track type mod/num [decrementvalue(def.10)]

HSRP Addressing

Switch(config-if)# standby group ip ip-address [secondary]

HSRP Load Balancing

Příklad konfigurace:

CatalystA(config)# interface vlan 50
CatalystA(config-if)# ip address 192.168.1.10 255.255.255.0
CatalystA(config-if)# standby 1 priority 200
CatalystA(config-if)# standby 1 preempt
CatalystA(config-if)# standby 1 ip 192.168.1.1
CatalystA(config-if)# standby 1 authentication MyKey
CatalystA(config-if)# standby 2 priority 100
CatalystA(config-if)# standby 2 ip 192.168.1.2
CatalystA(config-if)# standby 2 authentication MyKey

CatalystB(config)# interface vlan 50
CatalystB(config-if)# ip address 192.168.1.11 255.255.255.0
CatalystB(config-if)# standby 1 priority 100
CatalystB(config-if)# standby 1 ip 192.168.1.1
CatalystB(config-if)# standby 1 authentication MyKey
CatalystB(config-if)# standby 2 priority 200
CatalystB(config-if)# standby 2 preempt
CatalystB(config-if)# standby 2 ip 192.168.1.2
CatalystB(config-if)# standby 2 authentication MyKey
Switch(config-if)# show standby [vlan vlan-id | type mod/num] [brief]